Finally, new release!

Hello guys,
I finally found some time to release the new version of PDFsam. I want to apologize for the long delay but, as some of you may know, I worked hard on a couple of other projects (What A Cult and Sejda) in the past year and PDFsam was left a bit behind. Release 3 is not coming out any time soon so I decided to release version 2.2.2 with fixes to some of the most annoying bugs. Among the others:

  • Windows msi installation package supporting silent installation
  • New pdfsam-starter.exe and finally no more “javaw.exe not found” error message
  • Confirmation sounds are now working on Java 7
  • No more “invisible GUI” and crappy “delete gui-config.xml” workaround
  • Upgraded thumbnails generation libraries and langpack

As usual the new version can be downloaded here.
Please report back if you find any issue.
Enjoy

19 Comments

  • Reply

    I have been using 2.2.1 and it works well, but when trying to upgrade to 2.2.2 I keep receiving this error:
    “pdfsam” is damaged and can’t be opened. You should move it to the Trash.
    Using Mountain Lion on a MacBookPro 5,3.

  • Reply

    I tested it on Mac OS 10.8.2 and I found this solution working for me: http://www.pdfsam.org/bbforum/viewtopic.php?f=2&t=2599

  • Reply

    ah, good call. Didn’t even notice they added that feature, that fixed it. Thank you.

  • Reply

    I cannot start the application. Error message: “This application requires a Java runtime environment 1.6.0″. Title of the error window: “Cannot find Java runtime environment”. I installed this old environment (I had already installed version 7 update 9), but the error remains. My OS: Windows 7 Home premium.


    • Same problem …. always getting “Required java 1.6″….

  • Reply

    Is Java installed on your computer?

  • Reply

    Thanks for your great work!
    I love this program and I use on windows but I was hate shoot down Linux and open Windows to use it. (Ubuntu’s package is 1.5… Updf is the now my program on Ubuntu)

  • Reply

    Java 7 Update 1 (64 bit) has been installed in my computer with Windows 7 premium version 64 bit. Is it ready for PDFSam?


    • PDFsam runs with Java 1.6 or above so yes, it should run (should because they are not always 100% compatible).

  • Reply

    all attempts to load this latest version of pdfsam have failed keep getting message stating program in the windows msi installer missing. Any suggestions on how I might get round this. I’m running window 7 64bit and have loaded java 7.

  • Reply

    Variable [BOOKMARK_NAME] has no effect during split doc with bookmarks.

    Details here: http://sourceforge.net/tracker/?func=detail&aid=3589395&group_id=160044&atid=814265

  • Reply

    I’ve been using pdfsam for quite a while (thanks, by the way) and I still haven’t figured out the answer to this question:

    Why are both “Visual Document Composer” and “Visual Reorder” included? It seems to me that “Visual Reorder” is just a minor subset of “Visual Document Composer.” I find having both confusing.

  • Reply

    I have been using pdfsam under Linux for more than 3 years. Thanks for the good works and keep updating it.

    PDFSam used to work perfectly ok with Java 6 (6u2x) but seems to have an issue with Java 7 (I am running 7u9 at present). The “Destination output file” box does not accept any keyboard input under Java 7, even with the latest 2.2.2 release. If I switched back to Java 6, it works again. A work-around is to create a dummy pdf file in the destination directory via the console command:

    touch xxxx.pdf

    and then let pdfsam overwrites it as output file.

    I do not understand what is the root cause but hope that this issue could be fixed in future releases.

  • Reply

    I just want to thank you for the msi installers. Much appreciated!

  • Reply

    Running windows 8 and trying to split a 20Mo pdf file into 2 files with the last one having the last page only…..

    Both created files are 20Mo :( ……..Tried then various split with various number of pages and same behavior.


    • using pdfsam 2.2.2

  • Reply

    scusa ma sia la versione 2.2.0 che l’ultima scaricata e installata 2.2.2. continua a dare errore che non trova
    il file iavaw.exe, non capisco anche perché ha sempre funzionato. ho Windows 7 64 bit. forse qualche problema con java?

  • Reply

    I have used pdfsam with great results for the last couple of years. Recently it has stopped opening. I click on it to open it and nothing happens. Any thoughts as to why this could be?

  • Reply

    Hi. I paid for the advanced pdfsam, but could never get it to work on my mac. I’d now like to try the new release, but don’t wish to pay for it again. How can I download the advanced pdfsam using the key from my previous purchase? Thanks, Katie.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>